dtSearch Desktop/Network
Indexing and Search techniques

T207 — IDENTIFYING DUPLICATES, SELECTING & COPYING FILES

dtSearch Desktop/Network is a powerful search tool used by
professionals for a wide variety of tasks. This tutorial aims to
show you how to search using a “list of words”, how to identify
duplicates using the MD5 hash indexing option, how to sort and
select search results, and how to copy selected files. These are
all typical processes used in litigation, eDiscovery and forensic
searching.

Course Prerequisites
dtSearch Desktop/Network 7.88 or later
T207 search query and test documents (see Appendix)

Copyright © 2019 dtSearch UK. All Rights Reserved. This trainee manual can only be copied in its entirety complete
with all copyright notices. Individuals may use 30-day evaluation versions of the required software to carry out
the tasks in this course. Organisations who wish to run courses based on this material need to purchase trainer
manuals with answers, additional notes and training material and have licensed copies of each of the requisite
software products for each trainee.
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This training session covers several advanced topics of interest to those involved in litigation,
e-forensics, eDiscovery and early case assessment.

A common requirement in disputes that may require court involvement is “to meet and confer” to
identify what E-data to collect for possible use in litigation. This may involve discussing where the
data is stored, who created it and in what time period for example. A useful outcome could be
agreeing a list of search terms.

This tutorial shows some techniques that might be useful but should not be taken as legal advice.

Before beginning the training session, all copies of dtSearch Desktop must have the same

initial indexing and display setup. Access to the “List of words” and T207 test documents is also
required. This can be carried out by each trainee as part of the session or by an instructor before
the session starts (See Appendix).

Initial setup of dtSearch Desktop:

From the Options menu, choose Preferences > Indexing Options.

Select ‘Generate and index MD5 hashes...”. Other useful options for this type of search may be
automatically recognising email addresses, index document properties to see who authored a file
and index numbers in case sums of money etc are involved.

Preferences
Indexing Options Indexing options
- Indexing options
... Letters and words Automatically recognize dates, email addresses and credit card numbers in text
- Filtering options Index numbers
- Indexing resources Index document properties such as Author, Subject, etc.
[Jindex filenames as text Include path information

- File segmentation
[] dd file type name {Word, Excel, stc.) to documents

- Text fields
. File types [ index MIME headers in emails
Spider Options [ Index HTML scripts, styles, links, and comments

[1Index attachments in POF files
[JIndex links in PDF files

[ Index field names in XML files
[ Index field attributes in XML files

- Spider options
- Spider passwords
Search Options

- Search options []lgnore common HTML field names (<P, <I, <B>, etc.)in XML data
- Search results [Tindex XML files as plain text {without field searching)

- User thesaurus [ Index database files as plain text (withovt field searching)

... Macros

[JIndex properties of images embedded in documents
[ Enable numeric range searching (makes indexes langer)
[li3enerate and index MDA hashes for documents:

]

ocurnent Options

- Document display

Fonts.and ':':'Il':'rs‘ [ Generate and index SHAZ5E hashes for documents
- PDF view options [ Index hidden content in Office documents {such as macros)
... External viewers [Jindex NTFS Summary Information streams

[ Compatibility mode for Parallels Desktop for Mac
[]Index lists of flenames in ZIP and RAR archives

Default location for new indexes
|C:'-.Llsers'-.PCZE'-.Dncumerrts'-dtSearch Indexes’. &y

Cancel

TIP: To use the keyboard instead of a mouse to navigate, use Ctrl+Tab or Ctrl+Shift+Tab to move
down or back up in the left-hand panel. Use Tab or Shift+Tab to move down or up in the right-hand
panel.
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Next choose Letters and words.

We need to make sure the Alphabet file has the factory default settings. Click on the Alphabet file
Edit... button.

Preferences
Indexing Options Letters and words
- Indexing options
—"
- Filtering options |C:'-.Program Files {x86)\dtSearch'bin\default.abc [ | Edit...
- Indexing resources Noise word list
- File segmentation |C:'-.Program Files {x86)\dt Search'bin‘noise dat o | Edit...

- Text fields
- File types Maximum word length
- Spider options Hyphens

(®) Treat hyphens as spaces findex "first-class” as "first” and "class") frecommended)
() Treat hyphens as searchable findex "first-class” as "first-class™)

- Spider passwords

LI

earch Options

- Search options
() Ignore hyphens {index "first-class” as "firstclass")

- Search results
() Al three

- User thesaurus

- Macros

. [J For indexes created with the "All three™ option, treat hyphens as significant when
Document Options searching (so “first-class" will nct find "first class")
- Document display

- Fonts and colors [JInsert word breaks between Chinese, Japanese, and Korean characters in text.

- PDF view ocptions

.. External viewers

Cancel

Make sure that all characters from 33 to 36 are set to Space. 37 to Ignored, 38 to 44 to Space, 45
to Hyphen, 46 and 47 to Space. If you make any changes press Save before closing the dialog.

Edit Alphabet

Character Alphabet file

e | C:\Program Files {xBE}‘l.dtSearm‘lbin‘l.dehult.ab| Save

" 34 —

# 35

g 5 Character type Save As...
%% 37 () Letter (searchable text)

&

33 (®) Space (causes a word break)

39
( 40 () Ignored (not searchable, no word break)
) 4 (i Hyphen
= 42
+ 43
. 44 Lipper case letter
45 Lower-case equivalent:
46 W

M
4

Click the Edit... button alongside the Noise word list textbox. For this session we need an empty
noise word list. Create one by deleting all the words in the list, then press the Save As... button
and save it with a file name of none.dat. Now Close the dialog.
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Edit Moise Word List

Moise word list

C:\Program Files (x36)\dtSearchhinnone.dat |

Save As...
Words

Close

Finally set the Search results layout to include Checkbox, Location and Row Number as shown
below and click OK.

Preferences X

Indexing Options
Indexing options
Letters and words

Search results

o X ltems to include in search results Window layout
Filtering options Row number (® Horizontal split
Indexing resources Checkbox QO Vertical split
File segmentation [JRelevance score )
Text fields [ Hit count (;?Iumnlmzes o ——
. ize columns to fit conten v
File types Location
Spider Options o Mudff!:m!on cllate Search results font
. . [[] Modification time
Spider options Ot
e
Spider passwords [size
Search Options Dl ype Use default Choose Font...
Search options [[JIndex retrieved from Synopsis Color...
-Search results [C] First hits in context

User thesaurus Default Format

Macros

Document Options Always find the first hit when opening a document
Document display
Fonts and colors
PDF view options |:| Display the HTML <TITLE> as the filename for HTML files.

Automatically open the first document in search results
[]Display the PDF Title as the filename for PDF files

External viewers Disable JavaScript when displaying a retrieved HTML document
[[]Remember sort order from previous search

Number of search results lists to keep
100

Now we are ready to create an index. From the Index menu select Create index (Advanced) ...
Enter the name of the index as shown and enter MD5Hash exactly as shown into the
“Fields to display...” text box and click OK.
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Create Index (Advanced)

| T207

Cancel
Location Browse: Alt+Down
| C:WUsers\PC26 \Documents\dtSearch Indexes\T207 | @3: | Help

Indexing options
[]Cache document text in the index
[ ] cache documents in the index

[ ] Case-sensitive (treat 'Sample’ and 'sample’ as different words)

[ ] Accent-sensitive (treat accents as significant when comparing letters)

[ ] Support optional accent sensitivity {allows accents to be either ignored or treated
as significant when searching)

[ ] Make index compatible with an existing index.

Select index: e

Fields to display in search results
| MD5Hash

Legging
(®) Summary only () Detailed (istz all files indexed)

Select the index libraries that should indude this index
[+]C:\dtsearch724ixdib. ilb

Click Yes to add documents to your new index.

dtSearch

Index 'T207" created in folder
‘Cilsers\PC2E\DocumentsidtSearch Indexes\T207,

Would you like to add documents to the index now?

Yes Mo Cancel

In the Update Index dialog that appears, press the Add Folder... button.

Browse to Documents\T207\T207 Documents (See Appendix) and click OK.

The <+> at the end of the folder path indicates that subfolders will be indexed; if it is not present,
right click on the folder path and select include subfolders.
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Update Index

Index to update Index information
T207 | Mew... Index property Value
Actions Location C:\Users\PC26\Documents'dtSearch Ind
Index new or modified documents Word count a3
Clear index before adding documents Document count B
[]Remove deleted documents from index Index size 527 kb
[ ] Compress index after adding documents Data indexed 616
Parrant fAill Mo,
£ >
What to index Filename filters (optional)
C:\Users\PC26\Documents T 207207 Documents <+
Start
Indexing
£ >
Exdude filters Apply
Add Folder... Add Outlook. .. *exp =ik *.res *trg *th ®idb *.pdb =~ View L
* pch *.opt = lib "Deleted Items|™* tew Log
Add File... Remove *.cab *.mov *.psp *.bmp *.chi *.chm
* com *.dll *.exe *.gif *hlp *.ivi *.ivt Help
Add web... Clear List T *msl Fnls *.0bj F.o00 Trmi Tsys

Click the Start Indexing button. When indexing is complete press the Close button.

We are now ready to start searching!
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For a single keyword search, open the Search dialog. Press the Select None button to unselect any
previously selected indexes, then select the T207 index. Under Search features select Stemming,
and under Search for select Boolean search.

Enter a search query xfirstword and press Enter, this should return all the six documents.

Search Request More Search Options  Search History
Indexed word list Indexes to search
T207 w Select None Select All
2 thyme A |T207
2 tumeric
2 tumip
2 vanilla
2 wasabi
2 watercress
& xfirstword
& xlastword
]
Search request and ar niot w/h || wi2h |[fields...
wfirstword
Search features Search for
Stemming [] Symarym searching ) Ay words
[] Phonic searching Synonyms ) 4l words
[] Fuzzy =earching Related words (®) Boolean search {and, or, nat, ...}
4 User synonyms
Sort by relevance '
Retum best 5,000 matching files Benrrh
Browse Wards. . Thesaumns...

The best way to search using a long Boolean query is to use the Search for List of Words function.

List all the queries in a text file, one query per line. For this exercise use the sample
T207 Queries.txt file (see Appendix).
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Select Search > Search for List of Words... menu (Ctrl+Shift+W), browse to T207 Queries.txt
Select One Boolean expression per line.
Select the Stemming and Open search results in dtSearch when search is done checkboxes.

Select the T207 index to search.

arch for List of Words

Select the file with the list of words to search for Indexes to search
| C:Wsers\PC 26 \Documents T 207 T 207 Queries, twt e | [~]T207
Search type Search
() One word or phrase per line
() Natural language {find any word in the file)
(®) One Boolean (and, or, not, ...) expression per line Close
Search features Help
Stemming |:| Synonym searching
[ ] phanic Wordhet synonyms
(] Fuzzy searching WordMet related words
0 User Synonyms
Open search results in dtSearch when search is done Select All Select None
Search results export
Columns to expaort
[ ] Export search results to a text file Hit count Size
Type of file to create Hit count by word Modified date
Tab-separated (C5V) for Excel Filename with path Created date
Mame of file to create Display name Last access date
Output. csv Location User fields
Title
COpen File ]

Now press the Enter key or click Search, and Close the dialog when the search has completed.

After the search, click on the MD5Hash column header. This will sort the results by the field
MD5Hash, duplicate MD5 hashes will be displayed together.

The MD5 hash is based on the content of the file, duplicates are identified even if the files have
been copied to another folder and had their filenames changed.
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"(Bananas) or (Pear or berries) or (Potatoes) or..." -- fruit.bd - dtSearch

File Edit Search Index View Options Help

PHL=200

W

Y EE

Mame Location Md5Hash
1 W fruithbd Chilsers\PC2B\Documents\T20MT207 Documentsivegetables 4178bdel2bfcB9eb781c98ac21ddfc36

2 [ fruits.bt ChUsers\PC26\Documents\ T20MT207 Documentsifruits 4178bdel2bfcBIebh781c98ac2 1ddfc36

: g
53 [+ herbs and spices.bet ChUsers\PC2E\Documents\ T20MT207 Documentsiherbs B2dc923fd513431f849447h 7004 eaf cd

6 [ herbs and spices.bdt ChlUsers\PC26\Documents\ T20 T207 Documentsispices 2dc823fd 513431124944 7h Tobdelafc2

orange

grapefruit
banana
lime

Kiwi
pineapple
berry

Md5Hash: 4178bdel12bfc89eb781c98ac21ddfc36

Daone b files 12 hits 100%  diSearch 7.94.8615 64-bit

Click on the checkboxes (or Tab, Up/Down arrow to navigate to the row, then Shift + Space) to
select the files to be copied into a separate folder.

To select multiple rows to be copied, click on the first row you want to copy (or Tab, Up/Down
arrow to navigate to the row) then press Shift + Up/Down arrow to select the rows and click (or
Shift+Space) on the checkbox in the last row that you want to copy.

Select the Edit > Copy File... menu and choose the destination folder.

For investigative work there are options to preserve the folder names, file creation and last access

times. There is also an option to shorten long filenames.

Finally, click OK to start the copy operation.
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Copy Files

3 File(s) to copy
C:\Jsers'\PC26'Documents T 20 7T 207 Documentsifruits \vegetable. txt
C:\Jsers'\PC26'\Documents T 20 7T 207 Documentstherbstherbs and spices. txt Cancel
C:\Jsers'\PC26'\Documents T 20 7T 207 Documentsvegetables!fruit. bt

Destination
| C:\Users\PC26\Documents\Case Files acme corp E.; |

[Jpreserve folder names.

Preserve file creation and last access times.

[JWhen a document is in a container, such as a ZIP file or email archive, copy the entire
container file instead of just extracting the document.

[Jshorten long filenames.

Maximum length:

You can also generate a report from File > Print Search Results... with an option for only selected.

Generate Search Report

Documents to indude

() &ll documents in search results
(®) Only selected documents!

Type of report to generate
(®) List of files
i) Show hits in context

(") Indude full text of each file

Amount of context to indude
30 Waords

Paragraphs

A search report shows some or all of the documents in search
results in a printable format. When you dick Generate, the report
will be launched in your word processor so you can customize it
before printing.
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APPENDIX
T207 search query and test documents
Download T207.zip from this link: T207.zip

Unzip the file (right-click and select Extract All...) and put the extracted T207 folder into the
Documents folder on each student’s PC.

Search for List of Words

These files are intended to illustrate the use of the Search for List of Words function and the
effect of stemming on search results.

T207 Queries.txt contains a list of words or simple Boolean queries (Garlic and Peppers) on
each line, and dtSearch Desktop expands this into a Boolean search expression:

(Bananas)or (Pear or berries) or (Potatoes)or (Garlic and Peppers)
This search query will return all six test documents, even though none of them contain the exact
words Bananas, Pear, berries or Potatoes; this is because Stemming (and automatic conversion of
words to lower case) ensures that a search for Potatoes will find potato, a search for Pear will find

pears, a search for berries will find berry, and a search for Bananas will find banana.

Using the Search for List of Words function dtSearch will automatically add OR between each
search term and will add parenthesis around search terms to avoid ambiguity.

The Search for List of Words function is less prone to error than entering a long Boolean query in
the Search Dialog and ensures the same search query can be easily repeated by others.

For other tips see: https://www.dtsearch.com/images7/dtSearch-Tips-InsideCounsel.pdf

Screenshots

The screenshots used in the article are from dtSearch Desktop 7.94 running on Windows 10.

To make the title bars easier to distinguish the default white theme was changed. If you want to
do this in Windows 10 go to Settings>Personalization>Colours, uncheck Automatically pick an
accent colour from my background, check the title bars checkbox. Choose a custom colour such
as ‘storm’.

Accessibility

If you are running a training session for a group, it’s important that all participants can see (and
hear) projected screens or other material (e.g. PowerPoint slides) and those that need extra
contrast or other assistive technologies are catered for. Changing the mouse pointer scheme to
inverted extra-large and using the Display pointer trails option can be beneficial, these can be
edited in Windows 10 from Settings>Themes>Mouse pointer.

For more information see: https://www.w3.org/WAIl/teach-advocate/accessible-presentations/

Issue 5 Copyright 2019 dtSearch UK. All Rights Reserved 10


https://www.dtsearch.co.uk/media/68234/T207.zip
https://www.dtsearch.com/images7/dtSearch-Tips-InsideCounsel.pdf
https://www.w3.org/WAI/teach-advocate/accessible-presentations/

e

{

T207 — IDENTIFYING DUPLICATES, SELECTING & COPYING FILES

Settings

Home

Find a setting

Personalisation

2%
2
=2

Ay

il

Background

Colours

Lock screen

Themes

Fonts

Start

Taskbar

Issue 5

Colours

+ Custom colour

More options

Transparency effects

@ off

Show the accent celour on the following surfaces

[] start, taskbar and action centre

Title bars

Choose your default app mode

® Light
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